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The	  Joy	  of	  Micro-‐C	  
This document explains how to write code for the Micro Engines or “ME”s on 
the NFP-6xxx chip. We will use Netronome’s Programmer Studio SDK. 

 
There are over a hundred MEs on the chip, collected into a number of 
“islands”. Each ME has its own instruction store and local memory, shown as 
Code and Data in the above diagram. Each island also contains additional 
shared memory and special-purpose execution units that operate on data in 
that shared memory. (These are not shown in the above diagram, but we will 
come back to them in a little while.) Islands are not all identical. Some islands 
contain mostly MEs; some contain a few MEs plus other functionality such as 
PCIe interfaces or bulk-crypto; some islands contain only shared memory and 
special purpose execution units. 
 
We start with the SDK so that we can use its visualization facilities, which are 
helpful for understanding small examples. However, testing and debugging 
programs with hundreds of threads calls for different techniques, so later we 
introduce the command-line tools and we may even get to see sophisticated 
on-chip monitoring facilities such as the performance analyzer. 

1 Installing	  the	  SDK	  on	  Windows	  
 
What you will need: 
 

• An installer, for example:  
nfp-sdk-5.1.0.1-2085.9255e7cf9e87-setup.exe 

• A license file, for example: 
2014-12-05_10_34_53_156736.nsl or 
netronome-internal-use-sdk-license-135606-2015-03-31.nsl  

• A Windows PC or VM running Windows. Note that 6GB of RAM is 
strongly recommended. (With less that this, the NFP-6xxx chip 
simulator may not start reliably. Also, when some older versions of the 
SDK run on a VM with only one core, the simulator may not start at all.) 
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It is possible to run the SDK under Wine, but you will have to work out 
the details for yourself. 

 
Steps 
 

1. Double-click the installer in the usual way. (Note that the installer is 
“from an unknown publisher”. Don’t worry, just say Yes.) 
 

2. Accept all the defaults in the installer by clicking Next and then Install 
and finally Finish. 

 
3. Find the SDK and launch it. (It is called Programmer Studio, and its 

icon is a downward-pointing triangle.) 
 

4. You will be prompted to import a license file. Click Import License, find 
and select your license file in the file-selection dialog-box then click 
OK. 

2 Hello	  World	  (nearly)	  
 
It is of course traditional to start with a program that prints “Hello World” or on 
embedded systems to flash an LED or something similar. But we are writing 
code for a “Micro-Engine” processor (ME) which has no direct access to I/O 
facilities, so the traditional “Hello World” program for the ME merely reads 
integers from one initialized array in memory and writes them in reverse to 
another array. (This example was introduced in IXP2400/2800 Programming 
by Erik J. Johnson & Aaron R. Kunze, Intel Press 2003.) Of course, to be 
convinced that the program has actually done something, you need to be able 
to inspect the memory before and after, to see what has happened. So we will 
also learn how to do that. 
 
Steps 
 

1. Run the Programmer Studio SDK.  
 

2. From the File menu, select New Project… A dialog box appears. 
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3. In the New Project dialog-box: 
• Set Project name to Project, 
• Change the last element of the Location from Project to 

HelloWorld. (It is automatically filled in with the name Project as 
you type into the Project name box, but you need to change it. We 
do this to make cloning project directories easier.) 

• From the Chip Family/Variant list, select nfp-6xxx-b0, 
• Click OK. 

 
4. From the File menu, select New. A dialog box appears. 

 
5. In the dialog box: 

• From the list, select Compiler Source File, 
• Click OK. 

 
6. The main window of the SDK (at the top right) now becomes a text 

editing window. Into this window enter the following code: 
 

int	  old[]	  =	  {1,	  2,	  3,	  4,	  5,	  6,	  7,	  8,	  9,	  10};	  
int	  new[sizeof(old)/sizeof(int)];	  
	  
int	  
main(void)	  
{	  
	  	  	  	  int	  i,	  size;	  
	  	  	  	  size	  =	  sizeof(old)/sizeof(int);	  
	  	  	  	  for	  (i	  =	  0;	  i	  <	  size;	  i++)	  {	  
	  	  	  	  	  	  	  	  new[i]	  =	  old[size	  -‐	  i	  -‐	  1];	  
	  	  	  	  }	  
	  	  	  	  return	  0;	  
} 
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 Like so: 
 

 
 
 

7. From the File menu, select Save As... A dialog box appears. 
 

8. In the dialog box: 
• Set File name to main-‐hello, 
• Click Save. 
(As you can see from the title bar, the source code has been saved in 
your home directory as NFP_SDK\HelloWorld\main-hello.c.) 

9. From the Project menu, select Insert Network Flow C Compiler 
Source Files. A dialog box appears. 

10. In the file-selection dialog box, choose your main-hello.c file and click 
Open. If you now click into the tree-browsing pane at the top right of 
the SDK window, you will see that the source file main-hello.c has been 
inserted: 
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11. From the Build menu, select Settings… A dialog box appears. 
 

12. In the Build Settings dialog box: 
• Click the Compiler tab, 
• Click the New .list file… button, (a dialog box appears) 

 

 
 

• In the dialog box: 
o In the Filename box, enter: hello-‐program, 
o Click Open. 

• Click the Choose source files… button, (a dialog box appears) 
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• In the dialog box: 

o Click on main-hello.c, 
o Click the --> button, 
o Click OK. 

 

 
 

13. Still in the Build Settings dialog box: 
• Click the Linker tab, 
• Click the sub-tab List File Assignments 

 
 

• In the middle pane, click on i32.me0, 
• In the right-hand pane, click on hello-program.list 
• Click on the + button in-between these panes. 
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. 

14. Finally in the Build Settings dialog box click on OK. 
 

15. From the Build menu, select Build (or press F7). You will see the 
compiler output in the bottom right-hand pane: 

 

 
 

16. From the File menu select Save Project. (If you don’t do that, and 
close the SDK, your source files will be as you last saved them, but all 
configuration changes will be lost. The SDK does warn you about this if 
you try to close it down without saving the project.) 

3 Interlude:	  what	  is	  going	  on	  here?	  
 
Before actually running this program, it’s worth looking for a moment at what 
all that configuration was doing, and how it relates to the architecture of the 
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NFP chip. Remember that the NFP-6xxx chip contain many Micro-Engine 
processors collected into a number of “islands”: 

 
Since each ME has its own instruction store, different programs can be loaded 
into different MEs at startup. Therefore we need to choose a particular ME on 
which to run our Hello World program, and tell the SDK about our choice.  

 
In general, a program is compiled from a number of Micro-C source-code files 
(and supporting header files) which are linked together into a .list file. Each 
.list file represents one complete program, and we can arrange for copies of 
this program to be loaded onto one or more specified MEs. When we want 
different MEs to run different programs, we must arrange to produce different 
.list files, each compiled from particular Micro-C source code files, and to 
specify which ME is to be loaded with which .list file. (Of course, we can share 
Micro-C source-code and header files across several programs; in that case 
the .list file for each program would include the shared code.) 
 
In our Hello World example, we have only one program, which is linked into 
the .list file “hello-program.list”, and we only want to run it on one ME. At the 
end of step 13 above, the program represented by this .list file is configured to 
be loaded into ME number 0 in Island number 32. (This is a general-purpose 
ME island, containing 12 MEs and a small amount of shared memory.) 
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In our Hello World example, we also have only one Micro-C source file “main-
hello.c”. However, if you look more closely at the contents of the .list file (see 
the dialog box Compiler Sources at step 12 above) you will notice that it also 
includes library code from files “intrinsic.c”, “libc.c” and “rtl.c”. Due to the 
compiler’s enthusiastic dead-code removal, almost none of that library code 
appears in the image loaded into our ME. (As we will shortly see, the only 
remaining library code in the image is the exit() function.) 

4 Running	  the	  program	  
 
The SDK contains a cycle-accurate simulator for the NFP-6xxx chips. So, 
provided our programs are fairly short, we can develop and run them on this 
simulator. First we will disable the simulation for all but the single island where 
we have loaded our program, then we will start the simulator. 
 
Steps 
 

1. From the Simulation menu, select Options… A dialog box appears. 
 

2. In the Simulation Options dialog box: 
• Click the Enable Islands tab 

 

 
 

• Uncheck the All box, to disable all islands, 
• Check the  Iid:32 box (which says hello-program.list next to it), to 

enable island 32 only, 
• Click OK. 
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(The simulator will run somewhat faster if you disable islands that you 
don’t need.) 

 
3. From the Debug menu, select Start Debugging. This starts the 

simulator, which runs in a separate process from the SDK. You will see 
the announcement “Starting simulator” in the status-bar at the bottom 
of the SDK window, then “Waiting for simulator to become ready”. The 
logging pane at the bottom-right of the window shows various 
initialization messages from the simulator, then after a few seconds the 
SDK window will refresh itself, looking like so: 

 

 
 

Beneath the menu-bar at the top, where some of the buttons were 
previously grayed-out, now they are colored and active. The top-right-
hand pane now also contains a ThreadView tab, containing a tree-
browser showing all the MEs in all the islands.  
 

4. MicroEngine i32:0 in the ThreadView tab is distinguished by having a 
‘+’ sign next to it.  
• Double-click on MicroEngine i32:0. ‘+ hello-program.list’ appears, 
• Double-click on that. ‘Thread0’ to ‘Thread7’ appear: 
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• Double-click on Thread0. A thread-debug tab appears in the area 
where we were editing our Micro-C source code: 
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5. Note the >>>>> symbol in the gray margin at the left of the pane. This 
indicates the location in the source code corresponding to the current 
program counter. Naturally, you would expect this to be somewhere at 
the top of the main() function, not on the return statement at the end. 
What has happened? To get an insight, let’s have a look at the 
assembly code that the compiler has produced: 
• Click on the green-and-yellow documents-with-arrows symbol 

above the pane. The corresponding assembly code is shown, with a 
>>>>> symbol indicating the location corresponding to the current 
program counter. (You can click again to switch back to Micro-C.) 
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This is the assembly code for the whole program! (Including the 
exit() function which runs after main returns.) What has happened 
here is that the compiler is being surprisingly clever. It has unrolled our 
loop, and noticed that the assignments depend only on compile-time 
constants. We might have expected that. Unexpectedly, because we 
haven’t expressed any preference, it has also chosen to allocate the 
old and new arrays in memory which is private to this ME, and then 
noticed that the program now has no observable side effects. 
Therefore our main() function has been optimized to a return 
statement. 
 
Clearly, if we run this program, nothing very exciting will happen. But 
since we are here, let’s run it anyway. 
 

6. From the Debug menu, select Run Control > Go. The green traffic-
light in the toolbar at the top of the SDK window is replaced by a red 
traffic-light. On the right-hand side of the status bar at the bottom of the 
SDK window, you will observe a cycle counter ticking up. (Quite slowly: 
the simulator is running a faithful simulation of the hardware.) Let this 
run for a few seconds. If you let the cycle counter get to 200, this is 
plenty. 
 

7. From the Debug menu, select Run Control > Stop. The red traffic-
light is replaced by a green traffic-light, and the cycle counter stops. 
The assembly code window now looks like this: 
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The program counter is indeed now at the end of the assembly code, 
after the ctx_arb[kill] instruction which stops this thread. So at the 
end of this journey, we have after all written and run a program, 
although admittedly not the one that we initially intended to run. 
 

8. From the Debug menu, select Stop Debugging. The SDK window 
returns to its earlier source-editing configuration. 

 
For our next example program we will produce and run the Hello World 
program that we really wanted, but in order to understand that program, we 
first need to cover a little more background knowledge about ME threads and 
about the memories that they share. 

5 Interlude:	  Threads	  and	  Memories	  
 
As you will have worked out already, each ME has 8 “threads”. But what 
precisely does that mean? We understand that threads run in parallel, but 
there are different kinds of parallelism.  
 
So, for MEs: 
 

• Every ME is a separate processor which genuinely runs in parallel 
with all other MEs.  

• Every ME has its own separate program in its own private code 
store. 
 

But for threads on MEs: 
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• Each ME has 8 threads which are used for co-operative multi-
threading. At most one thread on an ME is actually executing code 
at any moment. A thread which needs to wait for something can 
yield the CPU; the ME will then switch context to another runnable 
thread. (This is very cheap: it takes only 2 cycles, because each 
thread has its own registers which therefore do not need to be 
saved on a context switch.) 

• Every thread on an ME runs the same program, held in the single 
code store shared by all the threads on an ME. (Obviously, each 
thread has its own program counter.) If you want the threads on an 
ME to behave differently, there is a function which returns the 
thread number, and you can test that in an if-statement. 

 
As previously mentioned, as well as the private memory of each ME, there are 
a variety of shared memories. We will now look more closely at one particular 
kind of shared memory, the “Cluster Target Memory” (CTM), which is 
available in most islands. (The reason for the rather odd name will become 
clearer quite soon. The “cluster” part is straightforward: “cluster” is another 
name for an island.) 

 
Code running on an ME can access data in the CTM which belongs to its own 
island using the “Command Push Pull” (CPP) bus, using special ME 
instructions which effectively dispatch an operation to an external “target” 
functional unit. (Thus explaining the “target” part of the CTM name.) 
 
And in fact, as you might guess from the fact that the CPP arrow protrudes 
outside the island in the above diagram, an ME can also access data in 
various other memories using CPP operations. This includes accessing the 
CTMs in other islands as well. We will return later to examine how big and 
how fast each of the different kinds of memories are, but now let’s look in a 
little more detail at how CPP operations work, and how they interact with 
threads in MEs. The following sequence diagram illustrates two CPP 
operations: thread 0 reads a value from the CTM; thread 1 writes a value to 
the CTM. (Time advances down the page). 
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• Starting from the top, all ME threads are ready to run. (We only show 3 

out of 8 threads for simplicity.)The ME chooses thread 0. This runs for 
a while, then issues a CPP read command for location X in the CTM 
and yields the CPU, asking to be signaled when the read is complete. 
The ME immediately switches context to the next ready thread (thread 
1).  

• Meanwhile the CPP read command has arrived at the CTM dispatcher. 
This forwards the command to the next available CTM thread, which 
then goes on to actually do the read from its local RAM. (There are 
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more than 2 CTM threads, but again for simplicity we don’t show them 
all.) 

• Back in the ME, thread 1 is running and it issues a CPP write 
command, to location Y in the CTM. However, it does not immediately 
yield. Instead it does some more work and then yields, asking to be 
signaled when the write is complete. The ME switches context to the 
next ready thread (thread 2). 

• Meanwhile, the CPP write command has arrived at the CTM dispatcher 
and been forwarded on to an available CTM thread. (Not the same 
thread as the read went to, because that is still busy.) 

• A little while later, that earlier read operation completes, and a Push 
message travels across the CPP bus back to ME 0. (“Push” and “Pull” 
are from the point-of-view of the CPP target.) The original read 
command specified the destination register on the ME, and the signal 
to be raised on completion. Thus, along with the data, the Push 
message also includes this register number, and the completion signal 
number. Since thread 0 is waiting for that signal, the ME now changes 
the state of thread 0 from waiting to ready. However, thread 2 still 
continues to execute. 

• However, shortly after this, thread 2 yields. (For reasons not indicated 
on the diagram.) Thread 0 is now the next runnable thread, so it is 
given the CPU. 

• Meanwhile, the write thread in the CTM is ready to retrieve the data 
which it needs (to write to its local RAM), and a Pull message travels 
across the CPP bus back to ME 0.The original write command 
specified the source register on the ME where the data can be found, 
and the signal to be raised on completion. The Pull message therefore 
includes this register number, and the completion signal number. The 
ME returns the value of that register to the CTM in another message. 
Note that although this is shown as arriving at thread 1, this Pull-return 
interaction proceeds autonomously, regardless of whether thread 1 is 
active or not. Since thread 1 is waiting for the signal that just arrived, 
after sending the return message, the ME changes thread 1’s state 
from waiting to ready. Note that the signal which just made thread 1 
ready indicates that it is now safe to re-use the register which 
contained the written data. The write operation itself is still not 
complete, and no further signal is given, even when it is complete. 
Thread 0 still continues to execute. 

• A little while later, thread 0 yields, and control passes back to thread 1. 
And so on … 

 
In order to understand the operation of the NFP-6xxx it is essential to 
appreciate the principles of CPP operation illustrated above. The primary aim 
of the architecture is to achieve high aggregate performance by keeping all 
functional units busy. (Not just the ME processors, but also the “Memory 
Engines” which implement CPP commands in memory units such as the 
CTM.) Hence most functional units have several threads, with fast context 
switching. In this way, whenever data is required from some distance away, 
the impact of the unavoidable latency can be diminished. Depending on the 
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structure of the application software, the effective cross-chip latency can in 
this way be reduced by roughly an order of magnitude. 
 
Note that: 
 

• An ME can issue several overlapping CPP commands without yielding 
(these can be to the same or to different targets) and can then wait for 
some or all of these operations to complete. 

• The “Memory Engines” which execute CPP commands can do a lot 
more than just read and write data. For example, they can do a variety 
of atomic operations, synchronization, queuing, hash-table lookup and 
so on. (There is a similarity here with RDMA operations over LANs, 
though obviously on a shorter timescale.) 

• Memory units are threaded as well as MEs, so they can have several 
operations in progress at the same time. (The number of threads 
available depends on the particular target and the particular Memory 
Engine within that target which implements the requested operation.) 

 
So, having as it were “looked behind the curtain”, let’s now go back and 
change our Hello World program slightly so that it reads and writes data in 
island 32’s CTM. Because this has a visible side-effect, it will not be optimized 
away. 

6 Hello	  World	  (really)	  
 
To save time, we will start by copying our existing Micro-C project then 
modifying it slightly. (This is why we earlier chose the name “Project” for the 
project file within the HelloWorld directory. That way we can clone a project by 
simply copying its directory in file explorer.) 
 
Steps 
 

1. If you are still in the SDK, from the File menu, select Exit. (If you are 
asked “Save changes to project ‘Project’?”, click Yes.) 
 

2. Open a file explorer window and navigate to the NFP_SDK directory 
where your SDK projects are stored. You should find a directory here 
called HelloWorld. Make a copy of that HelloWorld directory and 
rename it HelloWorldReally. 

 
3. Restart the SDK.  

 
4. From the File menu, select Open Project… A dialog-box appears. 

 
5. In the file-selection dialog-box: 

• Double-click on the HelloWorldReally folder, 
• Double-click on the Project.psproj file, 
• The dialog box disappears. 
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6. A dialog-box appears, saying “The project Project is in a different 
location than when last saved. Rebuild is required.” 
• Click OK. 

 
7. From the Build menu, select Rebuild. 

 
8. In the main code-editing window, modify hello-main.c as indicated 

below. (The shaded parts are new; unshaded parts are the same.) 
 
	  

#include	  <nfp.h>	  
__declspec(ctm)	  int	  old[]	  =	  {1,	  2,	  3,	  4,	  5,	  6,	  7,	  8,	  9,	  10};	  
__declspec(ctm)	  int	  new[sizeof(old)/sizeof(int)];	  
	  
int	  
main(void)	  
{	  
	  	  	  	  if	  (__ctx()	  ==	  0)	  {	  
	  	  	  	  	  	  	  	  int	  i,	  size;	  
	  	  	  	  	  	  	  	  size	  =	  sizeof(old)/sizeof(int);	  
	  	  	  	  	  	  	  	  for	  (i	  =	  0;	  i	  <	  size;	  i++)	  {	  
	  	  	  	  	  	  	  	  	  	  	  	  new[i]	  =	  old[size	  -‐	  i	  -‐	  1];	  
	  	  	  	  	  	  	  	  }	  
	  	  	  	  }	  	  
	  	  	  	  return	  0;	  
}	  

 
This introduces a few new things: 
 
• The include file nfp.h must be imported here because it contains 

the declaration of __ctx(). 
• The keyword __declspec introduces a storage-class modifier. In 

this case __declspec(ctm) means “place this in the Cluster Target 
Memory for this island”. 

• The function __ctx() returns an unsigned	  int in the range 0 to 7 
which is the number of the current thread. Remember that the same 
code runs on all the threads of an ME, one thread yielding to 
another in round-robin fashion. Using __ctx() in the above if-
statement has the effect of running the reverse-copying for-loop on 
only thread 0. (Threads 1 to 7 immediately return from main() and 
halt.)  

 
9. From the Build menu, select Build. Observe that the compiler output 

in the bottom right-hand pane has no errors. 
 

10. From the Debug menu, select Start Debugging. As before, the status 
bar at the bottom left shows how things are going, along with the 
simulator start-up messages in the pane at the bottom right. After a few 
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seconds, the simulator has started properly and the windows rearrange 
themselves. 

 
11. The top right-hand pane now has a ThreadView tab:  

• Double-click on MicroEngine i32:0. ‘+ hello-program.list’ appears, 
• Double-click on that. ‘Thread0’ to ‘Thread7’ appear, 
• Double-click on Thread0. A thread-debug tab appears at the top left 

of the SDK window. 
 

12. Observe that the >>>>> current position line in the C source now looks 
a lot more promising: 

 

 
 
 

13. Click on the green-and-yellow documents-with-arrows symbol to see 
the corresponding assembler code. Note that this also looks much 
more plausible. (If you look more closely you will find the two “mem” 
instructions which actually send the CPP read and write commands to 
the CTM.) Click on the green-and-yellow documents-with-arrows 
symbol to switch back to Micro-C. 
 

14. We will next set up a memory watch, so that we can see the CTM 
memory before and after our program runs.  
• From the View menu, select Debug Windows > Memory Watch 
• The memory watch pane appears at the bottom of the SDK window: 
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• In this pane, click on EMEM, EMEM DC, IMEM, CLS and ILA to 

deselect them, 
• Then click on the Add Watch button. A dialog box appears: 

 

 
 

 
• In the Add Memory Watch dialog-box: 

o Select type of memory to be CTM 
o Select the island to be i32.ctm 
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o Specify the range of addresses to be 0:1023, to see the first 
1K bytes of the CTM memory in island 32. 

o Click on Add Watch. A new line in the memory watch pane 
appears. Note that the Add Memory Watch dialog-box does 
not close. It is waiting in case you want to add another 
watch. 

o Click on Close to close the dialog-box. 
• In the memory watch pane, double-click on the new line labeled 

+ i32.ctm[0:1023]. You can now see the place in island 32’s CTM 
where our program’s data is stored: 

 

 
 

Before we run the program, have a closer look at the memory contents. 
There are a couple of puzzling features which we will return to and 
explain shortly: 
 
• You can see that the data you would expect for the old array starts 

at address zero. This is followed by the memory allocated to the 
new array, initialized to zeroes. However, there appear to be several 
copies of old and new. Why? 

• The new arrays appear to be bigger than the old arrays. Why? 
 
Note that “uninitialized” memory, starting from address 704 onwards,  
is actually loaded with the fill-pattern 0x5a5a5a5a. 
 

15. From the Debug menu, select Run Control > Go (or press F5, or click 
the green traffic-light button on the toolbar). We will soon learn how to 
use breakpoints and the simulator’s history mechanism. But for now, 
just observe the cycle-counter at the bottom of the SDK window. Let it 
run to around 1500 cycles. 
 

16. From the Debug menu, select Run Control > Stop (or press shift-F5, 
or click the red traffic-light button on the toolbar). Observe that, in the 
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Memory View pane at the bottom of the SDK window, some of the 
values which were previously zero have now changed, and these 
changed values are highlighted in red. These are the updated values 
which you would now expect to find in the new array. 

 
17. From the File menu, select Save Project. 

 
So now we have successfully run our “Hello World” program. (Perhaps you 
would like to take a short break and indulge in some small celebration?) 
 
Before we go on to look at breakpoints and the genuinely useful thread history 
viewer, let’s first explain those puzzling features of the memory viewer and its 
contents. 
 
First, why are there several copies of the old array? (And presumably of the 
new array too?) This is because: 
 

By default all variables are thread-local. 
 
So the definition 
 
__declspec(ctm)	  int	  old[]	  =	  {1,	  2,	  3,	  4,	  5,	  6,	  7,	  8,	  9,	  10};	  
 
causes separate arrays to be allocated in the CTM for each of the 8 threads in 
our ME. As you have seen, the loader initializes the data in each of these 
independent copies before the program runs. Then at runtime, when a 
particular thread uses the name old, it accesses its own copy of the array. 
(Because it is declared in the same way, there are also several copies of the 
new array as well.) 
 
This may appear a little mysterious, since isn’t it the case that all threads run 
the same program? Yes, that’s correct. But in that case, how can the name 
old refer to a different memory location in each thread? The answer is that a 
particular (thread-private) register is used as the base-address for thread-local 
data, and this register is initialized (by the loader) to the appropriate value for 
each thread before the program starts. Thus, although the code is the same, 
the addresses constructed by that code can be different in each thread. 
 
When we need to define a variable which is shared between all 8 threads of 
an ME, we can do it like so:  
 
__declspec(ctm	  shared)	  int	  old[]	  =	  {1,	  2,	  3,	  4,	  5,	  6,	  7,	  8,	  9,	  10};	  
 
If we do this, only one copy of the old array is allocated in the CTM, so now 
the name old refers to the same array in all threads. 
 
Secondly, why is there a gap of 8 bytes between the old array and the new 
array? It’s a feature. The compiler intends to force 16-byte alignment on all 
allocations longer than 8 bytes. Thus, thread 0’s old is 16-byte aligned 
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(address 0) and thread 0’s new is also 16-byte aligned (address 48). 
Unfortunately, thread 1’s old isn’t 16-byte aligned (address 88) because the 
compiler forgets to do this for the first allocation for a new thread, but acts as 
though it has done this for the subsequent allocations. [Fault THSDK-1832] 
 

7 Once	  more,	  with	  feeling	  
 
Next, we will use exactly the same example once more,  but this time we will 
use some more sophisticated debugging tools: history collection and 
breakpoints. 
 
Steps 
 

1. From the Simulation menu, select Options… A dialog box appears. 
 

2. In the Simulation Options dialog box: 
• Click the History tab 

 

 
 

• Check the Enable history collection box. (If you are unable to do 
this, that’s because you are still in debug mode. From the Debug 
menu, select Stop Debugging to exit debug mode, then try again.) 

• Ensure that Collect thread history and Collect reference history 
are now checked. 

• Click OK. 
 

(We will look at breakpoints next, then go on to use the thread history 
that we just enabled. , You have to enable history collection in the 
simulator from outside debug mode, so it’s best to set this up now.) 
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3. From the Debug menu, select Start Debugging. After a short while, 
the simulator starts, the SDK window rearranges itself and we are back 
where we were before. The HelloWorldReally program is ready to run. 
 

4. In the thread window: 
• Right click on the return	  0; statement. A menu appears. 
• Select Insert Breakpoint. A red dot appears in the left margin. 

 

 
 

5. From the Debug menu, select Run Control > Go. After a short while, 
a pop-up announcement box appears, saying “Breakpoint hit at line 15 
in thread ‘Thread1’.  
• Click OK. 

 
The cycle counter at the bottom left of the SDK window will indicate 
that we are at around 30 cycles. The data in the Memory View pane 
has not changed. What has happened? By default, breakpoints are set 
on all threads on an ME, so even though we set this breakpoint from 
the thread 0 window, it also applies to threads 1 to 7 as well. So this 
breakpoint fires when thread 1 reaches that point in the code, which 
happens shortly after thread 0 does its first CTM read operation 
(because at that point, thread 0 yields the CPU while it waits for the 
read to return). 
 
So, let’s see next how to restrict a breakpoint to apply only to a 
particular thread. 
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6. From the View menu, select Debug Windows > Breakpoints. A new 

Breakpoint pane appears at the bottom of the SDK window. (The 
Memory Watch pane squashes up to make room.) 

 

 
 

7. In the Breakpoint pane: 
• Check the Show Code Breakpoints box,  
• Click on the line Microengine i32:0 … which just appeared, 
• Click on the Properties button. A dialog box appears. 

 

 
 

8. In the Code Breakpoint Properties dialog: 
• Select the Applies only to microengine contexts checked below 

radio-button, 
• Check Context 0 (Thread0) 
• Click OK. 

 
9. Click the very small ‘x’ at the top left corner of the Breakpoints pane. 

The Breakpoints pane disappears and the Memory View pane 
expands, so it’s just as it was before. 
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10. From the Debug menu, select Run Control > Reset. This sets the 

simulator back to its initial state without stopping and re-starting the 
simulator, so it’s a lot faster than going out of and then back into debug 
mode. 
 

11. From the Debug menu, select Run Control > Go. This time, after 
considerably longer than before, a pop-up announcement box appears, 
saying “Breakpoint hit at line 15 in thread ‘Thread0’. The cycle counter 
at the bottom left of the SDK window will indicate about 1200 cycles. 
• Click OK. 

 
Observe that the changed memory locations are highlighted in red, as 
before. However, this time they have not all changed. The last element 
in the new array for thread 0 has yet to be written with the value 1. And 
yet the for loop has completed. What has happened? The last write is 
complete as far as the ME is concerned: the CTM has pulled the last 
value from an ME register, and the ME is now able to execute the 
remainder of thread 0’s code. But that last value has not yet been 
written to the CTM’s RAM, and this is what the Memory View pane 
shows. The value 1 is currently held only by some Memory Engine 
thread in the CTM. 
 
Since we have been collecting history, there is a very simple way to 
visualize this. 
 

12.  From the View menu, select Debug Windows > History. A new 
History pane appears at the bottom of the SDK window. (The Memory 
Watch pane squashes up to make room.) 
 

13. Grab the border between the Memory Watch pane and the History 
pane and re-size them so they each take about half the width of the 
SDK window: 
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14. In the history window, use the scroll-bar to see events at earlier times. 

Click on the Legend button for an explanation of the symbols and 
colors.  

 

 
 

If you hover your mouse over some of the elements you will get more 
detail on them. The ‘+’ and ‘-‘ magnifying glass buttons zoom in and 
out. The dotted vertical line represents the current time, and if you 
double-click on the coloured horizontal line somewhere else, the dotted 
line moves to there. And the thread window and Memory Watch pane 
shows the state of the system at that time. (You can also use the little 
green arrows to scroll forwards and backwards in time by one cycle.) 
 

 
 

You will notice that read operations take longer than write operations. 
This is because to read a value, the CTM actually has to get the value 
from its RAM and Push it into an ME register before the waiting ME 
thread can continue. However, for a write operation, the CTM merely 
has to Pull the value from an ME register; the internal CTM RAM write 
can happen later. If you use the history navigation facilities, you can 
scroll backwards and forwards in time and pinpoint exactly how long 
after the write operation was issued it takes for the data to change in 
the Memory View pane, which shows current CTM RAM contents. (It’s 
quite a lot later than you might expect.) 
 

15. Exit debug mode. Save the project. Close the SDK. 
 
You can learn more about the History pane and other debug windows in the 
NFP-6000 Development Tools User Guide, section 2.11. (Click on the 
InfoView tab in the pane at the top right of the SDK window.) 
 
We will next go on to look at the various kinds of memory on the NFP-6000. 
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8 Memories	  and	  memory	  regions	  
 
As we have seen, each ME has local code and data storage. We have also 
been experimenting with data in Cluster Target Memory (CTM) which can be 
shared between MEs. We will now take a look at the various memories which 
are available, and see how big they are and what their latency is.  
 
Let’s start with the local memory for each ME. Note that MEs have a “Harvard 
architecture” i.e. code and data occupy separate memories. Although it is 
obviously possible to somehow write to the code store, this happens by a 
somewhat round-about route, and we won’t discuss this here. 
 
Regarding the size and latency of an ME’s code and data store: 
 

• The code store for each ME is 8k instructions. This at first seems 
ridiculously small, but remember that the packet processing code 
running on MEs doesn’t have a lot of time to spend on each packet. 
Suppose that the NFP chip is in a 40G NIC which is carrying 
packets with an average size of 1000 bytes. This is equivalent to 
about 10M packets/sec (adding together transmit and receive).  
 
MEs execute one instruction per cycle, provided there are no 
pipeline stalls. The ME clock is 1.2GHz, and if we say that there are 
84 MEs available, then this gives a maximum of  around 1011 ME 
instructions/sec, and therefore around 10,000 instructions per 
packet, across all MEs that touch that packet. (And proportionally  
less with smaller average packet sizes or higher line-rates. That 
figure also assumes that MEs can be fully occupied with useful 
work and no cycles are wasted, which is not likely in practice.) 

 
• The data store for each ME is 4k bytes (shared between all 8 

threads). Again, this seems ridiculously small. However it is 
ameliorated somewhat by a similar number of registers (of which 
more later in this document) and by the various shared memories to 
which MEs have access over the CPP bus. 

 
The latency of this local memory is between 1 and 3 cycles, 
depending on factors which we will skip over for now. (Registers 
have 1 cycle access.) 
 

There are four other kinds of memory which are accessible as targets over the 
CPP bus: 
 

• Cluster Local Scratch (CLS). In most islands. 
• Cluster Target Memory (CTM). In most islands.  
• Internal Memory (IMEM). Two per chip. 
• External Memory (EMEM). Three per chip. 
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Note that all of CLS, CTM, IMEM and EMEM contain multiple functional units 
or “Memory Engines” which do many more operations than simple read and 
write. Except for CLS, which executes CPP operations in-order, all the other 
memories are threaded, so they can handle many operations in parallel.  
 
Here is a diagram of memory latency: 

 
The figures for CLS and CTM assume access from MEs in the same island. 
Access from other islands is possible, but slower. 
 
And here is a diagram showing the relative sizes of the memories, to scale: 
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Compared to programming in standard C on mainstream machines, one of 
the distinctive features of coding in Micro-C on the NFP is that it’s vital to keep 
in mind the fact that there are these different kinds of memories, and to 
allocate data in appropriate places. The different memories tend to be used 
for the following purposes: 
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• Local memory. Used for data which is needed for every packet. 
• CLS. Used for data which is needed for most packets. Also used for 

small shared tables. 
• CTM. Used for packet headers and for coordination between MEs and 

other sub-systems. 
• IMEM. Used for packet bodies. Used for medium-sized shared tables. 
• EMEM. Used for large shared tables, for example per-micro-flow 

statistics. (Data allocated to EMEM is stored in the attached external 
DRAM, and that by default the on-chip memory is used as a cache for 
that external DRAM.) 

 
Where data is not explicitly allocated in one of these places, the compiler 
attempts to keep it in registers where possible, then spills these registers to 
local memory when necessary.  When that is not enough, the compiler spills 
to further places (in an order controlled by a command-line flag, set in the 
SDK through the Build > Settings… dialog box). However, it is considered 
good practice to explicitly allocate data to particular places, and to leave as 
little as possible to the discretion of the compiler. 
 
We have already seen how to allocate data in one particular place: 
 
__declspec(ctm)	  int	  old[]	  =	  {1,	  2,	  3,	  4,	  5,	  6,	  7,	  8,	  9,	  10};	  
 
Here is how to allocate memory in all the different places: 
 

• __declspec(local_mem) The local memory for the the ME running 
this program. 

• __declspec(cls) The nearest CLS, i.e. the CLS in the island 
containing the ME running this program. 

• __declspec(ctm) The nearest CTM, i.e. the CTM in the island 
containing the ME running this program. 

• __declspec(imem) Some IMEM, usually the nearest on the chip to the 
ME running this program. 

• __declspec(emem) Some EMEM, usually the nearest on the chip to 
the ME running this program. 

 
The precise target chosen in each of these cases will be resolved at link-time, 
and may be different when the program is placed on different MEs. An 
alternative notation can be used where it is necessary to allocate memory in a 
particular chosen target: 
 

• __declspec(clsN) The CLS in island N. e.g. __declspec(cls32)  
refers to the CLS in island 32, regardless of which island contains the  
ME running this program. 

• __declspec(ctmN) The CTM in island N. e.g. __declspec(ctm33)  
refers to the CTM in island 33, regardless of which island contains the  
ME running this program. 
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• __declspec(imemM) The IMEM in island 28+M, regardless of where 
the program is running. 

• __declspec(ememM) The EMEM in island 24+M, regardless of where 
the program is running. 

 
In this way we can select the place where data is allocated. We can also 
control how many copies are allocated, and how these copies are shared 
between threads and programs. For example, we have seen that by default a 
separate copy of data is allocated for each thread in a program: 
 
__declspec(ctm)	  int	  old[]	  =	  {1,	  2,	  3,	  4,	  5,	  6,	  7,	  8,	  9,	  10};	  
 
And we can change this allocation, so that there is one single copy, shared 
between all the threads in a program running on one ME: 
 
__declspec(ctm	  shared)	  int	  old[]	  =	  {1,	  2,	  3,	  4,	  5,	  6,	  7,	  8,	  9,	  10};	  
 
In addition, we can also allocate one single copy which is shared between 
programs running on several MEs. This may either be a single copy across 
the whole chip, or a single copy shared between MEs in the same island, but 
different for MEs in different islands. So to summarize all the options, where 
place is one of the above places, we write: 
 

• __declspec(place) to get a separate copy in that place for every 
thread in every ME where the program is running. 

• __declspec(place	  shared) to get a separate copy in that place for 
every ME where the program is running. 

• __declspec(place	  export	  scope(island)) to get a separate copy 
in that place for every island which has an ME running this program. All 
MEs in a particular island get the same copy; MEs in different islands 
get different copies.  

• __declspec(place	  export	  scope(global)) to get a single copy in 
that place shared by every ME running this program.  

	  
Note that you may omit the scope() attribute in the latter two declarations. 
For allocations in CLS and CTM, if you omit the scope() attribute it is 
assumed to be scope(island); but for allocations in IMEM or EMEM, if you 
omit the scope() attribute it is assumed to be scope(global). 
 
To see how this works out in practice, we will explore this further with another 
small example program. 
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9 Exploring	  memory	  allocation	  
 
This is a very simple variant of our “Hello World” program. 
 
Steps 
 

1. Create a new project, or create a copy of one of your previous projects. 
 

2. Using File > New, create a new Micro-C source file with the following 
contents: 

 
#include	  <nfp.h>	  
__declspec(ctm	  export	  scope(island))	  	  
int	  old[]	  =	  {1,	  2,	  3,	  4,	  5,	  6,	  7,	  8,	  9,	  10};	  
__declspec(ctm	  export	  scope(island))	  	  
int	  new[sizeof(old)/sizeof(int)];	  
	  
int	  
main(void)	  
{	  
	  	  	  	  if	  (__ctx()	  ==	  0)	  {	  
	  	  	  	  	  	  	  	  int	  i,	  size;	  
	  	  	  	  	  	  	  	  size	  =	  sizeof(old)/sizeof(int);	  
	  	  	  	  	  	  	  	  for	  (i	  =	  0;	  i	  <	  size;	  i++)	  {	  
	  	  	  	  	  	  	  	  	  	  	  	  new[i]	  =	  old[size	  -‐	  i	  -‐	  1];	  
	  	  	  	  	  	  	  	  }	  
	  	  	  	  }	  	  
	  	  	  	  return	  0;	  
}	  

 
As before, the changes from our previous program are highlighted. 

 
3. Using Project > Insert Network Flow Compiler Source Files, insert 

your source file into the project. 
 

4. Using Build > Settings… open the Build Settings dialog-box, then: 
• Go to the Compiler tab and make a new list file for your program. 

Choose the above source file and select it as part of this list file. 
• Go to the Linker tab, go to the List File Assignments sub-tab, and 

and place the list file on both i32.me0 and i32.me1. 
• Still on the Linker tab, go to the General sub-tab, and check the 

Generate memory map file box: 
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This will allow us to see exactly where variables are being placed and 
how they are shared, by inspecting the generated memory map file. 

 
5. Using Build > Build, compile and link the project. 

 
6. Using Simulation > Options… open the Simulation Options dialog-

box, then: 
• Go to the Enable Islands tab and check that the island you need is 

enabled. 
 

7. Using Debug > Start Debugging, run the simulator. 
 

8. Using View > Debug Windows > Memory Watch open a memory 
watch pane, and in this: 
• Use Add Watch to add a memory watch for bytes 0:1023 of island 

32’s CTM. 
 

9. Observe that there is only one allocation corresponding to the array 
old and one for the array new, even though we have two programs 
running on separate MEs. 
 

10. Outside the SDK, open a file explorer window and navigate to the 
folder containing your project’s files. In that folder you will find a file 
with the extension “.map”. This is the memory map file, and it contains 
plain-text data. Open that file using a text editor (such as Notepad).  

 
You will see something like this, showing where the old and new 
arrays have been allocated: 
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Memory	  Map	  file:	  C:\Users\swray\NFP_SDK\Memories\Project_.map	  
	  Date:	  Wed	  Nov	  19	  15:00:15	  2014	  
	  	  
	  nfld	  version:	  5.1.0.1,	  	  NFFW:	  
C:\Users\swray\NFP_SDK\Memories\Project.nffw	  
	  	  
	  Address	  	  	  	  	  	  	  Region	  	  	  	  	  ByteSize	  	  	  	  	  	  	  	  Symbol	  
	  ===================================================	  
	  0x0000000000000030	  	  	  	  i32.ctm	  	  	  	  	  	  	  40	  	  	  	  	  	  	  	  	  	  	  	  	  	  i32._new	  
	  0x0000000000000000	  	  	  	  i32.ctm	  	  	  	  	  	  	  40	  	  	  	  	  	  	  	  	  	  	  	  	  	  i32._old	  
	  	  
	  ImportVar	   	   	   Uninitialized	  Value	  
	  ===================================================	  

	  	  
	  

11. This may feel a little unconvincing. To reassure yourself that including 
export in your source code has made a difference, try the following: 
• Using Debug > Stop Debugging, exit from the simulator. 
• Modify the source code so that instead of  

	  	  	  	  __declspec(ctm	  export	  scope(island))	  
it says  
	  	  	  	  __declspec(ctm	  shared) 

• Rebuild your program. 
• Start the simulator again and look at the CTM contents. 
• Observe that there are now two copies of old and new.  

 
12. Outside the SDK, look again in the folder containing your project’s files. 

Open the “.map” file again a text editor. You will now see that the 
allocation of the old and new arrays has changed: 

 
Memory	  Map	  file:	  C:\Users\swray\NFP_SDK\Memories\Project_.map	  
	  Date:	  Wed	  Nov	  19	  15:12:53	  2014	  
	  	  
	  nfld	  version:	  5.1.0.1,	  	  NFFW:	  
C:\Users\swray\NFP_SDK\Memories\Project.nffw	  
	  	  
	  Address	  	  	  	  	  	  	  Region	  	  	  	  	  ByteSize	  	  	  	  	  	  	  	  Symbol	  
	  ===================================================	  
	  0x0000000000000060	  	  	  	  i32.ctm	  	  	  	  	  	  	  40	  	  	  	  	  	  	  	  	  	  	  	  	  	  i32.me0._new	  
	  0x0000000000000000	  	  	  	  i32.ctm	  	  	  	  	  	  	  40	  	  	  	  	  	  	  	  	  	  	  	  	  	  i32.me0._old	  
	  0x0000000000000090	  	  	  	  i32.ctm	  	  	  	  	  	  	  40	  	  	  	  	  	  	  	  	  	  	  	  	  	  i32.me1._new	  
	  0x0000000000000030	  	  	  	  i32.ctm	  	  	  	  	  	  	  40	  	  	  	  	  	  	  	  	  	  	  	  	  	  i32.me1._old	  
	  	  
	  ImportVar	   	   	   Uninitialized	  Value	  
	  ===================================================	  
	  	  
As you can see, in this case all the allocations have been made in the 
same region as before: in the CTM of island 32. However, there are 
now two separate versions of each array. (Look at the right-hand 
“Symbol” column and observe that there is now a different copy of each 
array for me0 and for me1.) 
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It’s possible that you now feel happy with what’s going on here, but let’s 
pause a moment to reflect on exactly what happens when we say: 
 

__declspec(ctm	  export	  scope(island))	  
int	  old[]	  =	  {1,	  2,	  3,	  4,	  5,	  6,	  7,	  8,	  9,	  10};	  

 
We have two separate copies of the program being loaded into ME0 and ME1 
of island 32. Both programs declare and initialize the array old. There is only 
one shared copy of this array in the CTM, but the initializations do not conflict 
with each other. What is happening here? Why don’t they conflict?  
 
This works because provided they are consistent these memory allocations 
are unified between programs, even when more than one program initializes 
the data. (And this unification would happen in exactly the same way even if 
the programs loaded into ME0 and ME1 had separate source files which both 
contained the above declaration.) 
 
The memory-allocation unification algorithm works as follows: 
 
• For each ME, take all the symbols with external linkage (the “global 

symbols”) in the program loaded on that ME. Transform these symbols as 
follows: 

o Names declared export	  scope(global) are prefixed by an 
underscore. E.g. _variable 

o Names declared export	  scope(island) are prefixed by island 
number and underscore. E.g. i32._variable 

o Names declared shared are prefixed by island number and ME 
number and underscore. E.g. i32.me0._variable 

o Names that are thread local are renamed in a slightly different way 
that we won’t describe here. 

• Every transformed symbol is now unambiguous across the whole chip. For 
each ME with a program that declares a particular transformed symbol, 
associate the following information with that transformed symbol: 

o The place where the allocation to be made. E.g. i32.ctm 
o The size of the allocation in bytes. E.g. 40 
o If the declaration has an initializer, the data in that initializer. 

• For each transformed symbol, check that the associated data from every 
ME is consistent. The following must be true: 

o Every declaration must name the same place of allocation. 
o Every declaration must have the same size in bytes. 
o Every declaration which has an initializer must have identical data 

in the initializer. (It’s fine for some declarations to not have an 
initializer. Only the ones with an initializer need to match.) 

• Provided that the consistency check passes, data of the specified size is 
allocated to free memory in the specified place, with the specified initializer 
if any declaration has one, and otherwise with the initializer of “all zeroes”. 
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A few more points are worth remembering: 
 
• Recall that that you may omit the scope() attribute. For allocations in CLS 

and CTM, if you say export but omit the scope() attribute it is implicitly 
set to scope(island); however for allocations in IMEM or EMEM, if you 
omit the scope() attribute it is implicitly set to scope(global). Or in other 
words: export on its own, without scope() means different things in 
different places. Usually, it means the thing you wanted it to mean.  
 

• When the above memory-allocation unification algorithm checks for 
consistency between declarations in different programs, it only checks the 
length in bytes of an allocation, not the type. Therefore the following two 
declarations in two different programs will unify successfully: 

 
__declspec(imem0	  export)	  int	  new[10];	  

	  
__declspec(imem0	  export)	  char	  new[40];	  

 
• The attribute import may be used as an alternative to the attribute 

export: 
 

__declspec(imem0	  import)	  int	  new[10];	  
 

This is identical in meaning to export, except that a declaration which 
uses import is not allowed to have an initializer. In other words, any 
occurrence of import can be replaced by export, and any occurrence  of 
export in a declaration without an initializer can be replaced by import. 
The resulting storage allocation will be identical after any of those 
replacements. 

 
Having looked at the various memory units accessible across the CPP bus, 
let’s now turn back and look again at the local memory private to each ME, 
and at the internal architecture of the ME processor. 

10 ME	  architecture	  and	  other	  storage	  
 
The ME processor is a 32-bit machine, so all its internal registers and its 
private local memory are formed from 32-bit words. Here is a brief overview. 
 
(For a detailed description, see section 2 of the NFP-6000 Programmer’s 
Reference Manual, and section 5 of the NFP-6000 Databook available in the 
InfoView tab in the pane at the top right of the SDK window.) 
 
• General purpose registers. Each ME has 256 32-bit general purpose 

registers, shared between all 8 of an ME’s threads, giving 32 registers for 
each thread. Since each thread has its own registers, a context switch 
does not need to save any registers, and so it has the same overhead as a 
jump (2 cycles). Variables which are declared without any specified 
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storage location will by default be allocated to general purpose registers, 
unless they are larger than 64-bits, in which case they will be allocated 
elsewhere. (Usually to local memory.) 
 
When there are too many variables to automatically allocate to general 
purpose registers, some variables automatically allocated to registers are 
spilled, usually to local memory first, and then to other memories. The 
location and order of spilling can be set with compiler flags. 
 
Variables can be explicitly allocated to general purpose registers with the 
__declspec(gp_reg) annotation. Arrays which are indexed by values 
which vary at runtime cannot be allocated to general purpose registers, 
because general purpose registers cannot be indexed. However, it is fine 
to have constant indexes into arrays allocated in general purpose 
registers, since each access can be optimized to a particular register 
known at compile time. 
 
If an explicit allocation to general purpose registers is not possible, the 
compilation will fail with an error message. (This may happen because 
there are no free general purpose registers. It may also happen because 
an array will need to be indexed at runtime.) 

 
Physically, the general purpose registers are split into two banks, called A 
and B. Instructions which use two registers must take one register from 
each bank. Obviously the compiler takes care of this choice, but if you 
ever decide to study the generated assembler code, it’s worth knowing this 
because it explains the purpose of some apparently useless instructions. 

 
• Transfer registers. All data travelling over the CPP bus to or from CLS, 

CTM, IMEM or EMEM must go through a transfer register. Just to 
emphasize this: CPP data cannot come directly from or go directly to 
general purpose registers. It must instead go via transfer registers. There 
are 256 32-bit transfer-in registers, also known as “read registers”. These 
are used to receive data which arrives via a CPP Push operation. Several 
sequential registers can be transferred from the CPP bus in one Push 
operation. From ME code, these registers are read-only. They are shared 
between the 8 threads, so each thread has 32 transfer-in registers.  
 
There are also 256 32-bit transfer-out registers, also known as “write 
registers”. These are used to provide the data which is taken by a CPP 
Pull operation. Data from several sequential registers can be transferred 
onto the CPP bus in one Pull operation. From ME code, these registers 
are write-only. They are shared between the 8 threads, so each thread has 
32 transfer-out registers.  

 
Transfer registers can in principle be indexed, but the ME hardware has 
only one transfer index register, shared between all threads, which makes 
generating code to use this index register slightly tricky. The compiler does 
not currently attempt to do this, and arrays which are indexed by values 
that vary at runtime cannot therefore be allocated to transfer registers. 
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As we have seen, when Micro-C data is being read and written in the 
normal way, the compiler does all necessary allocation of transfer-
registers.  However, in library code with assembler inserts it is necessary 
to allocate data to appropriate transfer registers manually, using the 
annotation __declspec(read_register)  or 
__declspec(write_register). We will see some examples of this later.  

 
• Next-neighbor registers. There are also 128 further 32-bit registers, 

called next-neighbor registers. As the name suggests, these may be 
configured so that they communicate with neighboring MEs in the same 
island. With a different configuration they may be simply used as further 
storage, though with a 6 cycle latency. (See section 4.3 of NFP-6000 
Network Flow C Compiler User’s Guide for details.)  
  

• Local memory. There are 1024 32-bit words of local memory, shared 
between all threads. Variables can be allocated to this memory using the 
__declspec(local_mem) annotation. Remember that since variables are 
implicitly thread-local, there will be a distinct copy in local memory of each 
variable you declare, unless you use the __declspec(shared) annotation 
as described above. 

 
Data in local memory can include arrays with runtime variable indexes. 
The necessary index registers are replicated for each thread, which makes 
code-generation quite straightforward. However, local memory can only be 
accessed using these index registers, and this is slightly slower than 
access to general purpose registers: a new local memory read or write 
takes 3 cycles (compared to only 1 cycle for general purpose registers). 
However, accesses to sequentially following locations each take only one 
extra cycle. 

 
As you have already noticed, the major fundamental difference between 
Micro-C and standard C is the non-uniform memory model and the features to 
control sharing of data between threads and between programs on different 
MEs. However, there are other differences, which we will explore in the next 
section. 

11 Differences	  between	  Micro-‐C	  and	  standard	  C	  
 
As noted in the NFP-6000 Network Flow C Compiler User’s Guide, the 
Netronome Micro-C compiler accepts an extended subset of C-89. In part this 
is for historical reasons. This compiler began its independent life around a 
decade ago, when Intel stripped out features from the Intel C compiler relating 
to x86 code-generation and left only those relating to ME code-generation. 
The current Netronome Micro-C compiler is a direct descendent of that 
somewhat-lobotomized Intel C compiler. 
 
You have already seen a few of the extensions to standard C which are 
present in Micro-C, and a few more will be described in subsequent sections. 
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The principal ways in which Micro-C is a subset of standard C are: 
 

• No floating-point data-types of any kind. (Because these are not 
supported by the ME hardware.) 

• No recursive functions. (Because that would involve a kind of dynamic 
memory allocation. With this restriction, parameters and return values 
can be stored in fixed locations, and in fact since the compiler 
aggressively optimizes on a whole-program level, functions can often 
be in-lined and parameter initialization elided.) 

• No variable-length argument lists to functions. (For essentially the 
same reasons.) 

• No setjmp() or longjmp(). (In part because there isn’t a stack, which 
makes this more awkward to implement.) 

• Taking function addresses is forbidden. (So functions cannot be called 
through function pointers. Since there isn’t a stack, there’s no uniform 
calling convention: instead arguments to functions are written to fixed 
per-function locations, so it’s necessary to know what function is being 
called. Hence using function pointers must be forbidden. So taking their 
adrresses is too.) 

• Most standard library headers and supporting library functions are not 
present. (Many are not very useful in an embedded environment. In 
particular, dynamic memory allocation is problematic.) 

 
The Micro-C compiler also accepts a few C-99 extensions, for example the 
restrict type qualifier. For further details of all the above, see the NFP-6000 
Network Flow C Compiler User’s Guide, in particular section 4.12. 

12 Assembler	  inserts	  
 
At some point, in order to be comfortable with what is happening in all parts of 
a Micro-C program, you will want to read library code which includes 
assembler inserts. In order to be thoroughly in control of a system built in 
Micro-C, you may at some point also want to write library functions yourself. 
So in the next few sections we will take a few initial steps in this direction, 
enough so that when you want to travel down this path for yourself, you have 
a place to start from. 
 
We will begin with a very simple example, in which we send a CPP write 
command to the “bulk engine” in a CTM. This is very similar to the code which 
the compiler generates automatically if we do an assignment.  In fact, let’s 
start with a program which just does that: 
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#include	  <nfp.h>	  
	  
__declspec(ctm	  export)	  long	  long	  int	  new[16];	  
	  
int	  
main(void)	  
{	  
	  	  	  	  int	  i	  =	  __ctx()	  +	  8	  *	  ((__ME()	  &	  0x0f)	  -‐	  4);	  
	  	  	  	  new[i]	  =	  i;	  
	  	  	  	  return	  0;	  
}	  
 
This starts by declaring a long	  long	  int array with 16 elements, each of 
which is a 64-bit integer. (See section 4.2 of the NFP-6000 Network Flow C 
Compiler User’s Guide for the sizes of all basic types.) This is in the nearest 
CTM, and because of the export	  there is a single copy of this array shared 
by all MEs in an island. 
 
The initializer for variable i appears a bit complex. Remember that by default 
all variables are per-thread. The intention is that this program will be loaded 
onto  ME0 and ME1 of island 32 and that each thread across those two MEs 
will receive a unique value of i drawn from the integers 0 … 15, as if the 
following assignment had happened: 
 
	  	  	  int	  i	  =	  thread_number	  +	  8	  *	  me_number;	  
 
The built-in function __ctx(), as we have seen, returns the current thread 
number, in the range 0 …7. The built-in __ME() function returns a 
combination of island number and ME number within island, as if it were 
defined like this: 
 
int	  
__ME()	  
{	  
	  	  	  return	  (island_number	  <<	  4)	  +	  me_number	  +	  4;	  
}	  
 
There is a little bit-twiddling to unpick this, but the rest of the program is 
straightforward. 
 
If you’d like to try this out, load this program onto ME0 and ME1 in island 32. 
When you run it and inspect the CTM where the array new is located, you will 
see that the 64-bit values you would expect, from 0 to 15 have been loaded 
there. (The changed 32-bit words are shown in red. The words that remain 
zero before and after the write are still black. These words have been written, 
just with the same value that they had already.) 
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Let’s now modify the program to do the assignment to an element of the array 
“by hand” as it were, by explicitly sending a CPP Write command. 
 
#include	  <nfp.h>	  1	  
	  2	  
__declspec(ctm	  export)	  long	  long	  int	  new[16];	  3	  
	  4	  
int	  5	  
main(void)	  6	  
{	  7	  
	  	  	  	  int	  i	  =	  __ctx()	  +	  8	  *	  ((__ME()	  &	  0x0f)	  -‐	  4);	  8	  
	  	  	  9	  
	  	  	  	  __declspec(write_reg)	  long	  long	  int	  xfer;	  10	  
	  	  	  	  volatile__declspec(mem	  addr40)	  void	  *	  addr;	  	  11	  
	  	  	  	  unsigned	  int	  addr_hi,	  addr_lo;	  12	  
	  	  	  	  SIGNAL	  my_signal;	  13	  
	  14	  
	  	  	  	  xfer	  =	  i;	  15	  
	  	  	  	  addr	  =	  &new[i];	  16	  
	  	  	  	  addr_hi	  =	  ((unsigned	  long	  long	  int)addr	  >>	  8)	  &	  0xff000000;	  17	  
	  	  	  	  addr_lo	  =	  (unsigned	  long	  long	  int)addr	  &	  0xffffffff;	  18	  
	  19	  
	  	  	  	  __asm	  {	  20	  
	  	  	  	  	  	  	  	  mem[write32,	  xfer,	  addr_hi,	  <<8,	  addr_lo,	  2],	  ctx_swap[my_signal];	  21	  
	  	  	  	  }	  22	  
	  23	  
	  	  	  	  return	  0;	  24	  
}	  25	  
 
The changes to the previous program are highlighted. Let’s start at the end, 
with the assembler insert on lines 20 to 22, then work backwards to see how 
the pieces that we use there were created. 
 
First note that assembler inserts are introduced by __asm and enclosed in 
curly brackets. Each line inside the curly brackets follows assembler syntax, 
not C syntax. Thus although the line ends in a semi-colon, actually that is the 
assembler comment character, not the C statement-terminator. 
 
The mem operation is used for CPP commands to Memory Engines, followed 
by: 
 

• The mnemonic for the CPP command, in this case write32, which 
writes a number of 32-bit words. 

• A transfer register, in this case xfer. 
• The target address, broken into two pieces, in this case addr_hi and 

addr_lo. 
• The length of the data, in this case 2, which in this case means “2 32-

bit words” because this is a write32. 
• What to do next, in this case wait for completion of the CPP command, 

indicated by ctx_swap. 
• The signal used to wake this thread when the transfer is complete, in 

this case my_signal. 
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If you need to find out more detail about a CPP command, where can you 
look? The first place to look is the Programmers Reference Manual, in 
particular for this example look in section 2.2.39 Memory Unit, and within that 
at sub-section 2.2.39.14 MEM (Read and Write). This covers CPP commands 
provided by the “Bulk” Memory Engines which are available in CTM, IMEM 
and EMEM. (For further details you would then need to consult the Data 
Book, specifically chapter 9 Hierarchical Memory Sub-System, section 9.2 
Operational Details. Tables within this section specify the mapping of CPP 
mnemonics to the physical CPP commands, and give details of their 
operation.) 
 
Since we are doing a CPP write, the target memory will need to Pull the data 
it needs from a transfer register, or in this case from more than one transfer 
register, since transfer registers are only 32-bits wide. Thus, on line 10 we 
declare: 
 

__declspec(write_reg)	  long	  long	  int	  xfer;	  
	  	  	  	   
This allocates the necessary registers. (Two of them are needed in this case 
for the 64-bit long	  long	  int.) The compiler allocates adjacent registers, and 
the CPP command will contain the number of the first one. The length of the 
data to be Pulled is indicated separately, further on in the assembler 
instruction. (In this case it’s 2 because this CPP command measures length of 
data in 32-bit words. Some other commands measure in bytes.) 
  
The target address is indicated in a slightly messy way. The “natural” form of 
addresses in the NFP chip are 40-bit numbers. The most-significant 8 bits of 
this address indicates the target memory unit (CTM, IMEM, etc), and the 
least-significant 32-bits is the byte address within that memory unit. In order to 
supply this 40-bit address to the CPP write32 command, we need to provide 
it in two 32-bit registers, the first one containing the high 8 bits (addr_hi) and 
the second one containing the low 32 bits (addr_lo).  
 
So on line 11 we declare: 
 

volatile	  __declspec(mem	  addr40)	  void	  *	  addr; 
 
This is a 40-bit quasi-typeless pointer to data in some memory unit. When we 
take the address of new[i] and assign it to addr on line 16 the types are 
compatible. (We need the volatile in this case for the compiler to be happy, 
because variables declared export are implicitly volatile.) 
 
We then split addr into the two necessary pieces on lines 17 and 18. A slight 
subtlety here is that the top 8 bits of the 40-bit address must be placed in the 
most-significant 8-bits of addr_hi, with the lower-order bits zero. This is 
because the CPP assembler instruction takes addr_hi, shifts it up by 8 bits 
and adds it to addr_lo to form the address sent in the CPP command. (That’s 
the meaning of the <<8 notation: it means shift that one up by 8 bits.) 
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Finally, the ctx_swap[my_signal] at the end indicates that a context swap to 
another thread must be done after issuing this CPP command. A particular 
number signal is raised when the ME thread is ready again. (Remember that 
in the case of write operations, this is when the contents of the transfer 
registers have been Pull-ed. It takes a little while longer for that data to be 
written into the CTM RAM.) However, we don’t have to choose those signal 
numbers ourselves. Declaring and using a SIGNAL variable as we do here 
allows the compiler to do that book-keeping for us. 
 
If you run this new program on ME0 and ME1 of island 32 as before, you 
should find that it behaves exactly the same. (Well, if you look more closely 
you may find that the compiler chooses the write8 command rather than the 
write32 which we used, but the effect is essentially the same.)  
 
This whole exercise is clearly a lot of work to achieve by hand what the 
compiler manages perfectly well: writing data to memory using the CTM’s 
“bulk” engine. However, an efficient library implementation of memset() or 
similar would clearly be best using assembler instructions like this, writing a 
long block of data in each CPP transaction, rather than working a word-at-a-
time. Also, there are other Memory Engines as well as the “bulk” engine used 
in this example. We will next look at how to use some of the facilities provided 
by the “atomic” engine. 

13 Simple	  coordination	  
 
Consider the following program.  
 
#include	  <nfp.h>	  
	  
__declspec(ctm	  export)	  int	  my_data	  =	  0;	  
	  
int	  main(void)	  
{	  
	  	  	  	  if	  (__ctx()	  ==	  0)	  {	  
	  	  	  	  	  	  	  	  my_data	  =	  my_data	  +	  1;	  
	  	  	  	  }	  
	  
	  	  	  	  return	  0;	  
} 
 
If we load this onto ME0 and ME1 of island 32, what is the value of my_data 
when the program has finished in both places? Naively we might hope that 
the answer was 2, but of course there’s a race condition. The two active 
threads, one on each ME, are running in parallel and they start at exactly the 
same time, so the final result stored in my_data is 1.  
 
Now, the “atomic” engines have atomic increment commands, so if that was 
our object we could just use such command and solve our problem directly. 
However, I want to show you some more general things, so instead we will 
implement the basis of a semaphore and use that to protect the critical section 
in our program. 
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#include	  <nfp.h>	  1	  
	  	  2	  
	  __declspec(ctm	  export	  aligned(64))	  int	  my_semaphore	  =	  1;	  3	  
	  __declspec(ctm	  export	  aligned(64))	  long	  long	  int	  my_data	  =	  0;	  4	  
	  	  5	  
	  void	  6	  
	  semaphore_down(volatile	  __declspec(mem	  addr40)	  void	  *	  addr)	  7	  
	  {	  8	  
	  	  	  	  	  /*	  semaphore	  "DOWN"	  =	  claim	  =	  wait	  */	  9	  
	  	  	  	  	  unsigned	  int	  addr_hi,	  addr_lo;	  10	  
	  	  	  	  	  __declspec(read_write_reg)	  int	  xfer;	  11	  
	  	  	  	  	  SIGNAL_PAIR	  my_signal_pair;	  12	  
	  	  13	  
	  	  	  	  	  addr_hi	  =	  ((unsigned	  long	  long	  int)addr	  >>	  8)	  &	  0xff000000;	  14	  
	  	  	  	  	  addr_lo	  =	  (unsigned	  long	  long	  int)addr	  &	  0xffffffff;	  15	  
	  	  	  	  	  16	  
	  	  	  	  	  do	  {	  17	  
	  	  	  	  	  	  	  	  	  xfer	  =	  1;	  18	  
	  	  	  	  	  	  	  	  	  __asm	  {	  19	  
	  	  	  	  	  	  	  	  	  	  	  	  	  mem[test_subsat,	  xfer,	  addr_hi,	  <<8,	  addr_lo,	  1],	  \	  20	  
	  	  	  	  	  	  	  	  	  	  	  	  	  	  	  	  	  sig_done[my_signal_pair];	  21	  
	  	  	  	  	  	  	  	  	  	  	  	  	  ctx_arb[my_signal_pair]	  22	  
	  	  	  	  	  	  	  	  	  }	  23	  
	  	  	  	  	  }	  while	  (xfer	  ==	  0);	  24	  
	  	  }	  25	  
	  	  26	  
	  void	  27	  
	  semaphore_up(volatile	  __declspec(mem	  addr40)	  void	  *	  addr)	  28	  
	  {	  29	  
	  	  	  	  	  /*	  semaphore	  "UP"	  =	  release	  =	  signal	  */	  30	  
	  	  	  	  	  unsigned	  int	  addr_hi,	  addr_lo;	  31	  
	  	  	  	  	  __declspec(read_write_reg)	  int	  xfer;	  32	  
	  	  33	  
	  	  	  	  	  addr_hi	  =	  ((unsigned	  long	  long	  int)addr	  >>	  8)	  &	  0xff000000;	  34	  
	  	  	  	  	  addr_lo	  =	  (unsigned	  long	  long	  int)addr	  &	  0xffffffff;	  35	  
	  	  36	  
	  	  	  	  	  __asm	  {	  37	  
	  	  	  	  	  	  	  	  	  mem[incr,	  -‐-‐,	  addr_hi,	  <<8,	  addr_lo,	  1];	  38	  
	  	  	  	  	  }	  39	  
	  }	  40	  
	  	  	  41	  
	  int	  42	  
	  main(void)	  43	  
	  {	  44	  
	  	  	  	  	  if	  (__ctx()	  ==	  0)	  {	  45	  
	  	  	  	  	  	  	  	  	  semaphore_down(&my_semaphore);	  46	  
	  	  	  	  	  	  	  	  	  	  	  	  	  47	  
	  	  	  	  	  	  	  	  	  /*	  do	  something	  critical	  */	  48	  
	  	  	  	  	  	  	  	  	  my_data	  =	  my_data	  +	  1;	  49	  
	  	  50	  
	  	  	  	  	  	  	  	  	  semaphore_up(&my_semaphore);	  51	  
	  	  	  	  	  }	  52	  
	  	  53	  
	  	  	  	  	  return	  0;	  54	  
	  }	  55	  
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The code which had the race condition before has been marked as a critical 
section by sandwiching it between semaphore down and up. These are 
implemented in functions, and you will recognize some of the code there from 
our previous memory write assembler example. Let’s take this piece by piece. 

First on line 3 we have the declaration of the memory we will use as a 
semaphore. This is just an ordinary integer, initialized to the value 1. However 
there is a subtlety here, caused by the fact that in a CTM (and also in IMEM 
and EMEM) the bulk engine and the atomic engine are separate functional 
units, interacting independently with their shared multi-port RAM sub-system.  

The RAM sub-system interacts with the memory engines using 64-byte 
“cache-lines”. (These actually are cache-lines in the EMEM, but not really in 
the other memory units. Nevertheless, in all these places, data is moved in 
and out of RAM in these 64-byte units.) The purpose of the atomic engine is 
to provide atomic read-modify-write instructions. To do that it reads a cache-
line, operates on it, and writes it back. It can have several such operations in 
progress at the same time, and it ensures sequential consistency for 
operations on the same data. 

But there are no such “safety interlocks” between Memory Engines. An 
internal race condition is therefore possible if two Memory Engines operate on 
the same 64-byte cache-line simultaneously. Programmers must therefore 
ensure that this does not happen. The simplest way to do this is to use the 
following rule: 

Know what Memory Engines are operating on your data and when 
different Memory Engines operate simultaneously on data, use 
alignment annotations to ensure that data is placed in different 64-byte 
cache lines. 

This explains the align(64) annotation on lines 3 and 4. By insisting on 64-
byte alignment for each of these variables, we throw them into different 64-
byte cache-lines. 

This is of course almost the opposite of the rule of thumb that you 
might use on a coherent-cache multi-processor: in that case you might 
try to improve performance by placing a lock and the data protected by 
that lock in the same cache-line. Do not do that on the NFP-6xxx chip. 
Your program will go wrong. Unless … 

… Unless you access that data solely through the “atomic” engine. You 
can do this using the otherwise mysterious atomic_write  and 
atomic_read CPP commands offered by the atomic engines. These 
are simple reads and writes, but since they go through the atomic 
engine as well, there is no race-condition with other Memory Engines. 
There is a drop in performance however, since the atomic engines 
don’t have as high a memory bandwidth as the bulk engines. And 
furthermore, these additional reads and writes will tend to clog up the 
atomic engines and therefore slow down atomic operations for other 
threads. But this is a possible solution in some cases.  
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Because the CLS only offers in-order execution of CPP commands, these 
issues don’t apply to data stored there. 

The next interesting line is in the definition of function semaphore_down. On 
line number 20 we use the test_subsat CPP command to atomically 
decrement our semaphore. This is a saturating subtraction, so the 
semaphore will not go below zero.  (Hence the subsat in its name.) It returns 
the value of the semaphore before the subtraction happened. (Hence the test 
in its name.) 

This read-modify-write command uses two signals: one to indicate that the 
write register with the value to subtract has been Pull-ed, and another to 
indicate that the pre-modification value of the semaphore is in the read 
register. We must therefore in this case provide a  SIGNAL_PAIR, so that the 
compiler can choose two signal numbers for us. We cannot use ctx_swap for 
multiple signals, so in this case we must say sig_done[my_signal_pair] and 
then use the separate assembler instruction ctx_arb[my_signal_pair] to wait 
for both of them. 

Since there are two signals, you might expect there to also be two transfer 
registers, one for the write and one for the read. However, a little trick is used 
here. On line 11 we declare xfer as a read_write_register: i.e. as both a 
read transfer register and a write transfer register. The compiler allocates one 
of each with the same register number. This is the number which is used in 
the CPP command, and therefore the same number is used for both Pull and 
Push, and the same command format can be used. Note that when you write 
to xfer (e.g. on line 18) this variable name refers to the write register, but 
when you read from xfer (e.g. on line 24) the name refers to the read register. 
There is no other link between these; they are entirely separate registers. 

The implementation of the semaphore “down” operation is a little simplistic: if 
the semaphore cannot be immediately claimed, the thread effectively spins. 
Of course, other threads on the same ME can still run, since the spinning 
thread yields while its CPP commands are in progress. The overall 
performance might be poor if threads on many MEs simultaneously attempt to 
DOWN a semaphore which is not available, causing high load on an atomic 
engine. (As you will discover, there are CPP commands which directly 
implement several better ways for threads to coordinate, for example “rings”, 
“work queues”, “queue locks”, and so on.) 

The semaphore_up function is straightforward, and on line 38 illustrates the 
last kind of CPP command: an immediate command which does not use 
transfer registers. This particular command simply does an atomic increment, 
and does not return the new value. Because it uses no transfer registers, 
there is no need for a signal to indicate that that a transfer register is now free 
to be reused. (And therefore the thread will not in this case yield.) 

For more details about the above and other atomic operations, refer to the 
Programmers Reference Manual, sub-section 2.2.39.1 MEM (Atomic 
operations).  
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14 Pointers	  
	  
Before we go on to look at “intrinsic” library functions, let’s look in more detail 
at pointers, and at what happens when we use “unadorned” pointer types, 
with no type-qualifiers associating them with specific locations. As a general 
rule: 
 

It’s best to be completely explicit about the location of data. 
 
However, if you don’t do that, what happens? For example, consider: 
	  
#include	  <nfp.h>	  1	  
	  	  2	  
	  __declspec(ctm	  shared)	  long	  long	  unsigned	  int	  addr;	  3	  
	  	  4	  
	  void	  5	  
	  testing(int	  *px)	  6	  
	  {	  7	  
	  	  	  	  	  addr	  =	  (long	  long	  unsigned	  int)	  px;	  8	  
	  	  	  	  	  *px	  +=	  1;	  9	  
	  }	  10	  
	  	  11	  
	  int	  12	  
	  main(void)	  13	  
	  {	  14	  
	  	  	  	  	  int	  data	  =	  __ctx();	  15	  
	  	  	  	  	  int	  *p	  =	  &data;	  16	  
	  	  	  	  	  testing(p);	  17	  
	  	  18	  
	  	  	  	  	  return	  0;	  19	  
	  }	  20	  
  
On line 15 we declare an int	  variable called data, with a separate instance 
per thread. (Remember that without any further annotations, variable names 
are per-thread.) Now, normally, the compiler would try to put such variables in 
registers or failing that, local memory. But we take its address on line 16 and 
pass that address to a function on line 17. Because of this complication, the 
compiler chooses to place data in IMEM because if it’s there, the compiler can 
form a 40-bit address that will be meaningful anywhere. That’s the form of 
address expected as the int	  *	  px parameter to testing on line 6. 
 
So that we can see more easily what is actually going on, I’ve also declared 
(on line 3) a variable addr, a shared variable in CTM. (It’s a 64-bit unsigned, 
so there’s enough room.) The function testing copies its pointer argument 
px into here so we can see it in memory. Of course, there’s only one copy of 
this variable, so each thread will update the value in turn with a pointer to its 
own copy of data. The value which remains after the program has finished will 
be the address of data in thread 7, since that’s the last thread to update it. 
 
At this point you might want to run this program on ME0 of island 32, and set 
up memory watches for the IMEM & CTM, and engage history collection. Or 
you might choose to just read on. (This is a slightly fragile example, since it’s 
possible that some future compiler, the one you are using, may do something 
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different from mine. There’s no fundamental reason that the data has to go 
into IMEM0 — IMEM1 would be equally good. But at least this is a concrete 
example.) 
 
As confirmation of what’s happened, here is the .map	  file: 
	  
Memory	  Map	  file:	  C:\Users\swray\NFP_SDK\Testing\Project_.map	  
	  Date:	  Fri	  Dec	  12	  16:58:40	  2014	  
	  	  
	  nfld	  version:	  5.1.0.1,	  	  NFFW:	  C:\Users\swray\NFP_SDK\Testing\Project.nffw	  
	  	  
	  Address	  	  	  	  	  	  	  Region	  	  	  	  	  ByteSize	  	  	  	  	  	  	  	  Symbol	  
	  ===================================================	  
	  0x0000000000000000	  	  	  	  i28.imem	  	  	  	  	  	  32	  	  	  	  	  	  	  	  	  	  	  	  	  	  i32.me0.imem_40$tls	  
	  0x0000000000000000	  	  	  	  i32.ctm	  	  	  	  	  	  	  8	  	  	  	  	  	  	  	  	  	  	  	  	  	  	  i32.me0._addr	  
	  	  
	  ImportVar	   	   	   Uninitialized	  Value	  
	  ===================================================	  	  
  
As you can see from the above, the “thread-local storage” (tls) used for the 8 
copies of data is allocated starting at address 0 in the IMEM on island 28. 
(This is IMEM0. The 32 bytes allocated = 8 x 4 bytes per int.) By the end of 
the program, each version of data is set to one more that the value of 
__ctx() for that thread. 
 
The shared variable addr is allocated at the start of island 32’s CTM. It 
occupies 8 bytes. When the program finishes its value is 0x9c0000001c. This 
has 0x9c in the high order byte, indicating that it’s in imem0, and it has 
0x0000001c as the byte address within that IMEM. Now 0x1c = 28 in decimal, 
and 28 / 4 = 7, so this is the address of the 4-byte word corresponding to the 
variable data from thread 7. (As we would expect.) 
 
So far, that’s fairly straightforward. But what if we change line 15 so that it 
now reads: 
 
	  	  	  __declspec(local_mem)	  int	  data	  =	  __ctx();	  
  
When we take the address of this and attempt to assign it to p on line 16 this 
is an error. That’s because int	  * (and all other unqualified pointer types) are 
40-bit pointers to data which is in some memory unit, accessed using CPP 
commands. The above declaration now places data in the local memory of 
this ME, accessed using different machine instructions. It’s fine to take its 
address — since we can index local memory with values that vary at runtime, 
using such a pointer is never a problem. However it’s from a completely 
separate address-space from the 40-bit addresses which reference data 
allocated to memory units. If we want a pointer to refer to data in local 
memory, we would have to declare that pointer as: 
 
	  	  	  __declspec(local_mem)	  int	  *p	  =	  &data;	  
 
… and similarly in the parameter list of the testing function. If we do that, the 
program compiles and works in essentially the same way, but the value left in 
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addr is now just 0x1c (the most significant word is zero). If this value was cast 
to a 40-bit address and dereferenced, it would not access that data in local 
memory. That’s a different address-space. So, remember: 
 

There is no runtime representation of a general pointer to data 
which could be in either of these address-spaces. 

 
But what about void	  *	  ? Consider the following program: 
 
#include	  <nfp.h>	  1	  
	  	  2	  
	  __declspec(ctm	  shared)	  long	  long	  unsigned	  int	  addr;	  3	  
	  	  4	  
	  void	  5	  
	  testing(void	  *pv)	  6	  
	  {	  7	  
	  	  	  	  	  int	  *px	  =	  pv;	  8	  
	  	  	  	  	  addr	  =	  (long	  long	  unsigned	  int)	  px;	  9	  
	  	  	  	  	  *px	  +=	  1;	  10	  
	  }	  11	  
	  	  12	  
	  int	  13	  
	  main(void)	  14	  
	  {	  15	  
	  	  	  	  	  int	  data	  =	  __ctx();	  16	  
	  	  	  	  	  int	  *p	  =	  &data;	  17	  
	  	  	  	  	  testing(p);	  18	  
	  	  19	  
	  	  	  	  	  return	  0;	  20	  
	  }	  21	  
 
This would of course be fine in standard C, but with Micro-C we get a warning 
about the conversion of the int * p on on line 18 to the void * parameter pv. 
We are warned that this conversion may lose significant bits. i.e. That the 
compiler doesn’t guarantee that the part of the 40-bit address which identifies 
the memory unit will be correct. It would be best to heed this warning. The 
take-away lesson is that, unlike standard C, 
 

Bare void	  * and int	  * are not compatible types. 
 
However:  
 

Bare void	  * is compatible with any pointer type to data in local 
memory or to data in registers. 

  
Recall that we saw earlier that we can allocate data to the various kinds of 
registers, and we are allowed to take the addresses of such data. We are 
even allowed to dereference these pointers — providing that can all be 
optimized away at compile time. That’s because these pointers can’t have a 
run-time existence. The compiler has to identify which particular, fixed 
registers are referred to in each case. Therefore they can be passed as 
arguments to functions, but only to functions that are certainly inlined. Which 
brings us on to the topic of “intrinsic” functions. 
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15 Intrinsic	  functions	  
 
In this section we will address the last piece of the puzzle that you need to 
understand and make library functions. Most of the library functions which 
encapsulate assembler inserts are written as “intrinsic” functions. These are a 
kind of “inline” function and are therefore provided in .h header-files, rather 
than in .c source-files.  
 
In standard C, functions may be annotated with the storage-class inline, 
which indicates that the compiler may expand the code of the function inline at 
each place where it is called. (But the compiler isn’t obliged to expand these 
functions: it’s optional. It might, for example, choose to inline short functions 
but not long ones.)  
 
In Micro-C the following function annotations are available: 
 

• __noline  Never inline. 
• __inline   Same as the standard inline (i.e. it’s optional). 
• __forceinline  Not optional. Will always inline. 
• __intrinsic Always inline, partially-evaluate some conditionals 

    at compile-time. (Explained below.) 
 
Let’s just remind ourselves of what inline can do in standard C. For 
example, consider the following program: 
 
inline	  int	  	  
fn2(int	  x)	  	  
{	  	  
	  	  	  	  return	  2	  +	  x;	  	  
}	  
	  
inline	  int	  	  
fn(int	  x)	  	  
{	  	  
	  	  	  	  return	  1	  +	  fn2(x);	  	  
}	  	  
	  
int	  	  
main(void)	  	  
{	  
	  	  	  	  const	  int	  answer	  =	  42;	  	  
	  	  	  	  int	  x	  =	  answer;	  
	  	  	  	  int	  y	  =	  fn(x);	  
	  	  	  	  int	  z	  =	  fn(y);	  
	  	  	  	  return	  z;	  	  
}	  
 
Inlining is a behavior-preserving transformation which can be implemented in 
various ways, often in the code-generator, but it is simplest to think about it as 
a source-to-source transformation.  
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The above program could therefore be rewritten as follows, with parameters 
and return statements transformed into assignments to new local variables: 
 
int	  	  
main(void)	  	  
{	  
	  	  	  	  const	  int	  answer	  =	  42;	  
	  	  	  	  int	  x	  =	  answer;	  
	  
	  	  	  	  /*	  inline	  int	  y	  =	  fn(x);	  */	  
	  	  	  	  int	  fn_call1_local_x	  =	  x;	  
	  	  	  	  int	  fn_call1_result;	  
	  	  	  	  /*	  …	  and	  inline	  call	  to	  fn2(x)	  */	  
	  	  	  	  int	  fn2_call2_local_x	  =	  fn_call1_local_x;	  
	  	  	  	  int	  fn2_call2_result;	  
	  	  	  	  fn2_call2_result	  =	  1	  +	  fn2_call2_local_x;	  
	  	  	  	  fn_call1_result	  =	  2	  +	  fn2_call2_result;	  
	  	  	  	  int	  y	  =	  fn_call1_result;	  
	  
	  	  	  	  /*	  inline	  int	  z	  =	  fn(y);	  */	  
	  	  	  	  int	  fn_call3_local_x	  =	  y;	  
	  	  	  	  int	  fn_call3_result;	  
	  	  	  	  /*	  …	  and	  inline	  call	  to	  fn2(x)	  */	  
	  	  	  	  int	  fn2_call4_local_x	  =	  fn_call3_local_x;	  
	  	  	  	  int	  fn2_call4_result;	  
	  	  	  	  fn2_call4_result	  =	  1	  +	  fn2_call4_local_x;	  
	  	  	  	  fn_call3_result	  =	  2	  +	  fn2_call4_result;	  
	  	  	  	  int	  z	  =	  fn_call3_result;	  
	  
	  	  	  	  return	  z;	  
} 
 
Doing this removes the overhead of function calls and returns, but it also 
facilitates other optimizations. For example, in this case, by straightforward 
property-propagation and compile-time evaluation, the “const-ness” of 
answer can be traced through this straight-line code to the return statement, 
so the whole thing could be optimized to …  
 
int	  	  
main(void)	  	  
{	  
	  	  	  	  return	  48;	  
}	  
 
The key here is that the properties of particular arguments to inlined functions 
may be more specific than the general properties of parameters: in this case 
const	  int	  rather than int.  The compiler can therefore generate different 
code at each inlined function-call, code for each specific case rather than the 
a single common piece of code for a “one size fits all” function that needs to 
do the correct thing when called from all of those different places. 
 
In Micro-C the annotation __forceinline ensures that inlining will certainly 
occur: it is no longer just optional. The annotation __intrinsic also guarantees  
inlining but in addition it also partially-evaluates certain conditionals at 
compile-time. 
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Let’s next look at an example of partial-evaluation of conditionals at compile 
time. In the following example, we define a function which (on line 16) uses 
the compiler-provided “intrinsic” function __is_ct_const, which is true if its 
argument is known at compile-time to be constant. This , and similar 
functions, may only be used inside a user-defined function which is marked as 
__intrinsic. (They are not allowed in any other inlined functions.) 
 
#include	  <nfp.h>	  1	  
	  	  2	  
	  __declspec(ctm	  export	  aligned(64))	  int	  my_data	  =	  0;	  3	  
	  	  4	  
	  __intrinsic	  void	  5	  
	  atomic_add(volatile	  __declspec(mem	  addr40)	  void	  *	  addr,	  int	  x)	  6	  
	  {	  7	  
	  	  	  	  	  	  8	  
	  	  	  	  	  unsigned	  int	  addr_hi,	  addr_lo;	  9	  
	  	  	  	  	  __declspec(write_reg)	  int	  xfer;	  10	  
	  	  	  	  	  SIGNAL	  my_signal;	  11	  
	  	  12	  
	  	  	  	  	  addr_hi	  =	  ((unsigned	  long	  long	  int)addr	  >>	  8)	  &	  0xff000000;	  13	  
	  	  	  	  	  addr_lo	  =	  (unsigned	  long	  long	  int)addr	  &	  0xffffffff;	  14	  
	  	  	  	  	  15	  
	  	  	  	  	  if	  (__is_ct_const(x)	  &&	  x	  ==	  1)	  {	  16	  
	  	  	  	  	  	  	  	  	  __asm	  {	  17	  
	  	  	  	  	  	  	  	  	  	  	  	  	  mem[incr,	  -‐-‐,	  addr_hi,	  <<8,	  addr_lo,	  1];	  18	  
	  	  	  	  	  	  	  	  	  }	  19	  
	  	  	  	  	  }	  else	  {	  	  20	  
	  	  	  	  	  	  	  	  	  xfer	  =	  x;	  	  	  	  	  	  	  21	  
	  	  	  	  	  	  	  	  	  __asm	  {	  22	  
	  	  	  	  	  	  	  	  	  	  	  	  	  mem[add,	  xfer,	  addr_hi,	  <<8,	  addr_lo,	  1],	  \	  23	  
	  	  	  	  	  	  	  	  	  	  	  	  	  	  	  	  	  ctx_swap[my_signal];	  24	  
	  	  	  	  	  	  	  	  	  }	  25	  
	  	  	  	  	  }	  26	  
	  	  }	  27	  
	  	  	  28	  
	  int	  29	  
	  main(void)	  30	  
	  {	  31	  
	  	  	  	  	  volatile	  int	  x	  =	  __ctx();	  32	  
	  	  33	  
	  	  	  	  	  if	  (__ctx()	  ==	  7)	  {	  34	  
	  	  	  	  	  	  	  	  	  atomic_add(&my_data,	  1);	  35	  
	  	  	  	  	  	  	  	  	  atomic_add(&my_data,	  x);	  36	  
	  	  	  	  	  }	  37	  
	  	  38	  
	  	  	  	  	  return	  0;	  39	  
	  }	  40	  
  
You will recognize most of the lines in this program from the earlier 
semaphore example. In this case we are defining an “atomic add” function, 
which will use the incr assembler instruction if it can (when incrementing by 
a compile-time constant equal to 1).  Otherwise it falls back to using the more 
general atomic add assembler instruction. The main advantage of using the 
incr instruction is that  it doesn’t need to wait for a completion signal, 
because it doesn’t use any transfer registers. Thus the second call to 
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atomic_add in main can be executed immediately after the first, and in fact 
they overlap in their execution by the “atomic” engine of the CTM where 
my_data is allocated: 
 

 
 
As well as __is_ct_const, the following similar functions are available. They 
return true when evaluated at compile time, if their argument is a pointer to … 
 

• __is_in_reg(void	  *)	    … a register. 
• __is_read_reg(void	  *)	    … a read transfer register. 
• __is_write_reg(void	  *)	    … a write transfer register. 
• __is_xfer_reg(void	  *)	  	  	   … a transfer register (either). 
• __is_read_write_reg(void	  *)	   … a read-write transfer register.  
• __is_in_lmem(void	  *)	    … data in local memory. 

 
The purpose of these is to find out the location of data passed as a void	  * 
parameter to a user-defined intrinsic function, and then to select appropriate 
code in each instance. (This works for the above locations, but as we saw 
above, a bare void * is not guaranteed to hold a 40-bit pointer to data in 
memory units. In that case you should use a qualified void type such as 
volatile	  __declspec(mem	  addr40)	  void	  *	  instead.) 
 
As a rather contrived example, consider the following code: 
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#include	  <nfp.h>	  1	  
	  	  2	  
	  __declspec(ctm	  export)	  int	  new[10];	  3	  
	  	  4	  
	  __intrinsic	  int	  5	  
	  dereference(void	  *	  pv)	  6	  
	  {	  7	  
	  	  	  	  	  int	  result;	  8	  
	  	  	  9	  
	  	  	  	  	  if	  (__is_in_lmem(pv))	  {	  10	  
	  	  	  	  	  	  	  	  	  result	  =	  *((__declspec(local_mem)	  int	  *)	  pv);	  11	  
	  	  	  	  	  }	  else	  if	  (__is_in_reg(pv))	  {	  	  12	  
	  	  	  	  	  	  	  	  	  result	  =	  *((__declspec(gp_reg)	  int	  *)	  pv);	  13	  
	  	  	  	  	  }	  else	  {	  14	  
	  	  	  	  	  	  	  	  	  result	  =	  42;	  15	  
	  	  	  	  	  }	  16	  
	  	  17	  
	  	  	  	  	  return	  result;	  18	  
	  }	  19	  
	  20	  
int	  21	  
	  main(void)	  22	  
	  {	  23	  
	  	  	  	  	  __declspec(gp_reg)	  int	  reg	  =	  1;	  24	  
	  	  	  	  	  __declspec(local_mem	  shared)	  int	  local	  =	  2;	  25	  
	  	  26	  
	  	  	  	  	  if	  (__ctx()	  ==	  0)	  {	  27	  
	  	  	  	  	  	  	  	  	  new[0]	  =	  dereference(&reg);	  28	  
	  	  	  	  	  	  	  	  	  new[1]	  =	  dereference((void	  *)	  &local);	  29	  
	  	  	  	  	  }	  30	  
	  	  31	  
	  	  	  	  	  return	  0;	  32	  
	  }	  33	  
 
This is doesn’t do anything at all useful, other than illustrate that we can give 
pointers to local memory and pointers to registers as arguments to a user-
defined intrinsic function. Inside that function we can select different code at 
compile-time based on which kind of argument was supplied. (If you run this 
to check, you will observe that afterwards, new[0] = 1 and new[1] = 2, as you 
would expect. The variable local is declared on line 25 as shared so that it 
does certainly get put in local memory, not optimized to a register. But 
because of that we also have to get rid of the volatile attribute which is 
implicit to shared variables, by casting the address on line 29 to a void	  *.) 
 
The operation of inlining these user-defined intrinsic functions is like a weak 
version of Lisp macros: some conditionals are evaluated at a time after 
parsing but before code-generation. Precisely which conditionals are 
evaluated at compile-time and which at run-time is less crisply defined in 
Micro-C than with Lisp macros. Since there is no difference syntactically 
between conditionals evaluated at compile-time and run-time, this must be 
determined by some data-flow analysis, and there must be some level of 
complexity where the compiler can no longer guarantee to do the necessary 
property-propagation. (In the limit that would amount to solving the halting 
problem.)  
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However, you can be confident that your conditionals will be evaluated at 
compile time provided that: 
 

• Every argument to an __is_... function is the name of a parameter of 
the user-defined intrinsic function in which it appears. (For example the 
parameter pv in the above example.) 

• Every user defined intrinsic function is called with arguments which are 
simply a variable name, & variable name, or  a literal, rather than any 
more complex expression. (For example the arguments &my_data and 
the digit 1 in the previous example.) 

 
In part to simplify this problem, the compiler also enforces the rule that user-
defined intrinsic functions can only call other user-defined intrinsic functions or 
built-in intrinsic functions. 

16 Next	  steps	  
 
This document stops rather abruptly here. Clearly there is much more material 
to cover: 
 

• Examples of other coordination mechanisms: rings, work-queues, etc 
• Bigger example programs (using typical library functions). For example 

a simple packet classifier with multiple workers. 
• Command-line toolchain for Linux. Compiling and linking. Inspecting 

simulation data. How to do test-driven design. 
• Using the real chip. How to interact with the real chip via the drivers. 
• Using the performance analyzer (non-invasive bus-monitoring) for 

debugging. 
• … and so on. 

 
The intention is to provide this material in future, but to focus on areas for 
which there is a demand. So let me know. 
 

 stuart.wray@netronome.com	  
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